开往-友链接力

今日踩坑:node-sass不支持node15,使用dart-sass代替node-scss

早上一个uni-app cli项目npm install报错,定位到node-sass

一开始以为是node-gyp的错,因为报错信息有一句Try to update node-gyp,但是仔细一看是一个叫win32-x64-88_binding.node的包404了。

然后去https://github.com/sass/node-sass/releases/tag/v5.0.0看发现支持node15的版本还在Pre-release状态。

npm i node-sass@5.0.0 //失败 不存在这个版本

弃坑 改用dart-sass

npm rm node-sass -D
npm i sass -D

项目根目录新建vue.config.js,修改loader。

module.exports = {
    css: {
        loaderOptions: {
            sass: {
                implementation: require("sass") // This line must in sass option
            }
        }
    }
};

之后就一切正常了。
完结撒花.jpg

发表新评论